Tuesday, May 25, 2010

Google App Engine 0.0.13 gems released

We just released the 0.0.13 google-appengine gem. We published the latest App Engine SDK, and we're now using the jruby-jars gem published by the JRuby team. We also have some bug fixes to the appengine-apis gem, and the dm-appengine gem now supports Discriminators (single-table-inheritance):
  • App Engine Tools updated to version 0.0.13
  • App Engine Rack updated to version 0.0.9
  • App Engine SDK updated to version 1.3.4
  • App Engine APIs updated to version 0.0.16
Currently, appengine-rack depends on jruby-jars 1.4.1, but we have a pre-release version that will allow you to install any version of JRuby you want (by specifying it in the Gemfile).
More Coming Soon - We found an obscure issue with JRuby 1.5.0 on App Engine, but we expect to see this addressed in JRuby 1.5.1. Folks that want to use jruby-openssl 0.7 will need to hold untill JRuby 1.5.1. In the next few days, I plan to publish guides for Rails 2.3.8 and pure-Java Nokogiri.
RailsConf Session - Ryan Brown and I will be giving a talk at RailsConf, "Scaling Rails on App Engine with JRuby and Duby". You won't believe how far we've come in one year. David Masover will be there to bring us up-to-speed on the work he's doing with the DataMapper adapter. We'll also share highlights from Google I/O, and review the App Engine product roadmap.
Hackfest at RailsConf - Google is sponsoring a Hackfest at RailsConf on June 9. We'll have food, drinks, and even some swag to give away. Ryan and I will be helping folks with Duby and JRuby on App Engine. Other Googlers will be on-hand to help folks with Apps Marketplace integration and we'll get folks signed-up beforehand to use Google Storage for Developers. More details to follow.

1 comment:

  1. Hey, I can't make it to RailsConf, but I'd love to get in on Google Storage for Developers. tim.inman@gmail.com